Installed a Yoshimura Alpha exhaust last night - 2017+ Kawasaki Z650 Forum
 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 11-22-2018, 08:26 AM Thread Starter
Junior Member
 
Mliebs's Avatar
 
Join Date: Nov 2018
Posts: 1
Installed a Yoshimura Alpha exhaust last night

I bought this bike new about a month ago and couldn't hold off on starting mods. I did a ton of research between this and Akrapovic but really liked the deep sound of the Yoshimura better. I don't know if they changed the O2 sensor location or my wiring was a little longer but the 02 sensor wiring length was perfect. I've seen several posts about having to reroute it due to it being tight but mine was fine. I also noticed they no longer pack the exhaust in expanding foam, at least mine wasn't. I planned on trying it without the DB killer first and then adding it if it was too loud. After hearing it without the DB killer I'm not sure I'm going to even try installing it. I haven't had a chance to take it out yet but just from starting it in the garage the pipes are already starting to change to a nice shade of gold.
Attached Thumbnails
Click image for larger version

Name:	IMG_0782.jpg
Views:	197
Size:	219.8 KB
ID:	4599   Click image for larger version

Name:	IMG_0789.jpg
Views:	176
Size:	186.0 KB
ID:	4601  
Mliebs is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 12-26-2018, 12:17 PM
Junior Member
 
POWERMAN's Avatar
 
Join Date: Dec 2018
Location: Toronto, Canada
Posts: 27
Nice!

I had the Yoshi installed as well..loving it so far!

Thanks to Tremonte for all his headway into these mods : )
POWERMAN is offline  
post #3 of 3 (permalink) Old 04-06-2019, 11:59 PM
Junior Member
 
Join Date: Apr 2019
Posts: 6
I have also installed a Yoshimura Alpha exhaust on the 2018 z650 and ran into an issue. The bike wont start anymore. At first, it was because I blew an FI fuse. replaced it and it started right up. i rode it maybe 100ft down the street and it died. Wouldn't start once again. There is an engine light. I have charged the battery. The bike is getting spark, receiving fuel, and i have installed the Dynojet fuel controller(with Ninja 650 Yoshi map). I have no idea why it still wont start.
Please let me know if you might know anything.
motodude is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Z650 Yoshimura Alpha Install Tremonte Exhaust And Headers 56 08-09-2018 03:44 PM
Selling a Yoshimura Alpha Works Race Exhaust System Full CF Muffler MattMPD Exhaust And Headers 0 07-03-2018 09:36 PM
Yoshimura Alpha Works Race Exhaust System Kawasaki Z650 / Ninja 650 MattMPD Kawasaki Z650 Parts 0 07-03-2018 09:31 PM
Z650 Yoshimura Alpha Dyno Tremonte Exhaust And Headers 7 05-11-2017 01:07 PM
Kawasaki Z 650 - stock vs. Yoshimura Alpha T Race Series tech199 Exhaust And Headers 1 02-26-2017 05:20 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome