Need help Engine oil Question - 2017+ Kawasaki Z650 Forum
 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 07-26-2017, 11:38 AM Thread Starter
Super Moderator
 
czrlaker's Avatar
 
Join Date: May 2017
Location: El Centro, CA
Posts: 245
Garage
Need help Engine oil Question

So I changed the oil on my motorcycle @ just about 700 miles. I replaced the filter with a K&N one and the oil full synthetic. But only 300 miles since the last oil change and my engine oil looks dark and milky, I have attached pictures and info on the oil used and the oil filter. Any thoughts?
Attached Thumbnails
Click image for larger version

Name:	IMG_20170726_082112_1501083305925.jpg
Views:	221
Size:	71.0 KB
ID:	1353   Click image for larger version

Name:	Screenshot_20170726-083354-picsay_1501083423155.jpg
Views:	239
Size:	50.3 KB
ID:	1361   Click image for larger version

Name:	Screenshot_20170726-083413-picsay_1501083437771.jpg
Views:	161
Size:	73.2 KB
ID:	1369   Click image for larger version

Name:	Screenshot_20170726-083436-picsay_1501083449273.jpg
Views:	187
Size:	44.5 KB
ID:	1377  
czrlaker is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 07-26-2017, 05:54 PM
Senior Member
 
Tremonte's Avatar
 
Join Date: Mar 2017
Posts: 262
That is more than likely trapped condensate. Ride the bike for a bit, then look at it again. It shouldn't look milky after that, as the moisture will have evaporated. It's a common thing to happen in the warmer months when humidity rises. Nothing to be alarmed about, unless it doesn't go away after the engine is fully warmed and the oil has circulated. A 30 minute ride should be plenty to clear it up, but you'll more than likely see it again.

Bored? Looking for info? Check here: www.tremonte.tv
Tremonte is offline  
post #3 of 3 (permalink) Old 07-26-2017, 06:04 PM Thread Starter
Super Moderator
 
czrlaker's Avatar
 
Join Date: May 2017
Location: El Centro, CA
Posts: 245
Garage
I ride 40 mins to work each way. I checked it when I got to work, then again when I got home, was the same. I'll most likely try another oil change.
czrlaker is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
LED runner lights - question amire Kawasaki Z650 General Discussion 3 07-26-2017 05:47 PM
Engine Temps? newyorkien Engine Discussions 2 07-25-2017 08:55 AM
Engine light Dashboard indicator ON after first revision OrtigoNover Kawasaki Z650 General Discussion 2 07-07-2017 01:59 AM
temp meter question frypot Engine Discussions 22 05-31-2017 06:06 PM
Check engine mount torque Shamsul Kamal Engine Discussions 4 05-28-2017 08:54 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome