4k rpm bog - 2017+ Kawasaki Z650 Forum
 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 08-21-2019, 07:49 PM Thread Starter
Junior Member
 
Join Date: Aug 2018
Posts: 3
4k rpm bog

Alrighty so I'm on a 2017 with about 6500k miles on the bike running a yoshi alpha exhaust with the dynojet 4 powercommander, using 88 octane fuel(I'm in utah so high elevation). So recently about the past 500 miles-ish once I'm cruising and i let off barely and drop to around 4k the bike bogs down way bad, throwing me forward slightly if I'm not anticipating it anyone else have any issues with this?
Minikx65 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 08-23-2019, 08:20 PM
Super Moderator
 
czrlaker's Avatar
 
Join Date: May 2017
Location: El Centro, CA
Posts: 261
Garage
Quote:
Originally Posted by Minikx65 View Post
Alrighty so I'm on a 2017 with about 6500k miles on the bike running a yoshi alpha exhaust with the dynojet 4 powercommander, using 88 octane fuel(I'm in utah so high elevation). So recently about the past 500 miles-ish once I'm cruising and i let off barely and drop to around 4k the bike bogs down way bad, throwing me forward slightly if I'm not anticipating it anyone else have any issues with this?
What gear are you in. What's your speed? I know this bikes engine breaking is aggressive. I like it as I constantly use it. If it's just random then you should get it looked at, could be dangerous and it would be good information for these forums.

WhitexShadow
czrlaker is online now  
post #3 of 3 (permalink) Old 08-26-2019, 07:03 PM Thread Starter
Junior Member
 
Join Date: Aug 2018
Posts: 3
Second and 3rd gear seems to be where it's most aggressive, I seen some one saying you can adjust the engine braking so I wonder if mine is out of adjustment
Minikx65 is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome