broke the o2 sensor, cant start the bike - 2017+ Kawasaki Z650 Forum
 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 05-26-2018, 07:06 PM Thread Starter
Junior Member
 
Join Date: May 2018
Posts: 2
broke the o2 sensor, cant start the bike

good evening,

I would like to know if the z650 can start without o2 sensor ? I change the exhaust i broke the sensor, now the z650 won't start. Any idea ?
belligerent is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 11-16-2018, 02:30 PM
Junior Member
 
Join Date: Feb 2018
Location: DFW
Posts: 6
I was able to start the bike with the entire exhaust taken off, multiple times. This probably wasn't a good idea but the only thing that happened was the check engine light came on. After installing new exhaust and putting the O2 sensor back in, it took about 100 miles for the light to reset and go off.
Tyler Wayne McMullen is offline  
post #3 of 5 (permalink) Old 12-14-2018, 02:09 PM
Member
 
Join Date: Jan 2018
Posts: 58
There may be something else at play if the bike wont turn over. All a bad/broken 02 sensor would do is cause the bike to run hot and run horribly at higher speeds.
Ziggs is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 04-07-2019, 12:23 AM
Junior Member
 
Join Date: Apr 2019
Posts: 6
I have a similar issue with mine (2018 abs). I installed a new exhaust and now the bike wont start. one of the o2 sensor wires got clipped during installation. I noticed it and rewired it. could this have any correlation with it not starting?
motodude is offline  
post #5 of 5 (permalink) Old 04-07-2019, 09:34 AM
Junior Member
 
Join Date: Apr 2019
Posts: 6
It turns over. and there is an engine light. it seems to be getting fuel but maybe its not.
motodude is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
First bike, new to motorcycling! WHISKEYjack_CDN Z650 Owners Registry And Check In Area 1 08-22-2017 10:18 PM
My Bike Fell Over :) spoole76 Kawasaki Z650 General Discussion 9 07-27-2017 06:04 AM
How to use Rapid Bike ECU Tremonte Engine Discussions 3 06-14-2017 03:54 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome