Sprockets - 2017+ Kawasaki Z650 Forum
 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 07-26-2018, 07:06 PM Thread Starter
Junior Member
 
Join Date: Jul 2018
Posts: 3
Hey all,

I’ve got the 2018 Z650, I’m attempting to do a sprocket and chain replacement on it, my first go, but before I take it all apart, can anyone tell me what I should be setting my tension wrench to for when I put them back on so I don’t over or under tighten?

Any hints and tips would also be awesome please!
Random206 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 07-27-2018, 07:19 AM Thread Starter
Junior Member
 
Join Date: Jul 2018
Posts: 3
Ok so I thought I’d start as I needed to get it done, and I’ve had to cut the chain off as it’s the manufacturer chain and doesn’t appear to have a master link that I can see. I’ve still got the chain but I can’t get the sprocket off the bike. I can’t even begin to get it to move, it’s locked on tight!

Any ideas?

I’ve tried taking off the back wheel and locking it around the rear axel, but no go, I tried locking it in with a screw driver like I saw on a YouTube video...ended up bending the screw driver! It’s unreal how tight this is!
Random206 is offline  
post #3 of 5 (permalink) Old 07-27-2018, 05:41 PM
Senior Member
 
Tremonte's Avatar
 
Join Date: Mar 2017
Posts: 262
Front sprocket? Did you flatten out the lock washer first? The best way is to leave the rear wheel in place, flatten the retaining washer, and with the bike on it's side stand, press down on the rear brake while slightly leaning over the bike, and break it loose that way. It's about 90ft-lbs of force, but will feel way more if the washer hasn't been dealt with first.

Bored? Looking for info? Check here: www.tremonte.tv
Tremonte is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 11-25-2018, 01:55 AM
Junior Member
 
oldfart's Avatar
 
Join Date: Feb 2018
Location: Lampang, Nth. Thailand
Posts: 13
Garage
G'day everyone. Speaking of sprockets, after nearly 12 months using alternate sprockets front and rear without any issues, my dealer here in Thailand is telling me that this is the reason why my 2017 has suddenly started flashing the gear indicator and the yellow-coloured engine symbol is constantly showing. This apparently means the DFI Diagnostics is not working properly because of the sprocket change. He is at a loss to explain to me why this problem has just started and didn't start when they fitted the new sprockets (Vortex).
Any thoughts, anyone? Cheers
oldfart is offline  
post #5 of 5 (permalink) Old 11-26-2018, 07:40 PM
Junior Member
 
oldfart's Avatar
 
Join Date: Feb 2018
Location: Lampang, Nth. Thailand
Posts: 13
Garage
Sorry, I should have written "aftermarket", not "alternate". Just for the record, I actually went with Tremonte's original discussion 14 front, 47 rear. Cheers.
oldfart is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome