Kawasaki Z650 banner
1 - 7 of 7 Posts

· Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
So I bought my z around 4000 mi and now it has closer to 7000, it has always had the problem of when i let off the throttle on a hard pule and then get back on the throttle (happens the most in second gear) it misfire pretty bad. I was wonderin if this could be solved by a tune or if other maintenance is required?
 

· Registered
Joined
·
18 Posts
Hm interesting, I bought mine new and it has a similar (maybe same) issue since new. When I get back on the throttle I hear a pop when it happens. I used to think I ran over a stick or a rock or something that popped initially, but then it woudl happen usually in the same spot where the same acceleration condition happened...
 

· Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
Hm interesting, I bought mine new and it has a similar (maybe same) issue since new. When I get back on the throttle I hear a pop when it happens. I used to think I ran over a stick or a rock or something that popped initially, but then it woudl happen usually in the same spot where the same acceleration condition happened...
I ended up biting the bullet and getting a tune from a local shop, 700$ all said and done!. The issue got better but is still there so I took the bike back to see if they could do more. Ill keep you updated.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top